Вывод всей истории в задаче комплексного процесса

Публикация № 882870

Разработка - Практика программирования

1С:Документооборот

В статье описывается, какие изменения нужно сделать, чтобы в задаче комплексного процесса выводилась вся история (по всем процессам), а не только история текущего процесса.

К примеру, есть комплексный процесс, состоящий из согласования и подписания. После прохождения согласования пользователь получает задачу подписания и хочет тут же видеть, как прошло согласование. Просматривать визы в карточке документа не хочет, слишком много телодвижений.

В качестве решения предлагается выводить всю историю выполнения комплексного процесса.

Для этого нужно внести изменения в модуль менеджера регистра сведений "История выполнения задач".

1. Заменить код функции ИсторияПоБизнесПроцессу:

// Возвращает описание истории переданного бизнес-процесса
Функция ИсторияПоБизнесПроцессу(БизнесПроцесс) Экспорт
	
	//ИсторияВыполнения = "";
	//
	//УстановитьПривилегированныйРежим(Истина);
	//
	//Запрос = Новый Запрос("ВЫБРАТЬ
	//	|	ИсторияВыполненияЗадач.Описание
	//	|ИЗ
	//	|	РегистрСведений.ИсторияВыполненияЗадач КАК ИсторияВыполненияЗадач
	//	|ГДЕ
	//	|	ИсторияВыполненияЗадач.БизнесПроцесс = &БизнесПроцесс");
	//	
	//Запрос.УстановитьПараметр("БизнесПроцесс", БизнесПроцесс);
	//Выборка = Запрос.Выполнить().Выбрать();
	//
	//Если Выборка.Следующий() Тогда
	//	ИсторияВыполнения = Выборка.Описание;
	//КонецЕсли;
	//
	//Возврат ИсторияВыполнения;
	
	//{
	
	ИсторияВыполнения = "";
	
	УстановитьПривилегированныйРежим(Истина);

	Если ЗначениеЗаполнено(БизнесПроцесс.ВедущаяЗадача) Тогда
		
		ИсторияВыполнения = Доработка_ИсторияПоБизнесПроцессу(БизнесПроцесс);
		КомплексныйПроцесс = БизнесПроцесс.ВедущаяЗадача.БизнесПроцесс;
		
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ДанныеБизнесПроцессов.БизнесПроцесс КАК БизнесПроцесс
		|ИЗ
		|	РегистрСведений.ДанныеБизнесПроцессов КАК ДанныеБизнесПроцессов
		|ГДЕ
		|	ДанныеБизнесПроцессов.ВедущаяЗадача.БизнесПроцесс = &КомплексныйПроцесс
		|	И ДанныеБизнесПроцессов.БизнесПроцесс <> &БизнесПроцесс
		|
		|УПОРЯДОЧИТЬ ПО
		|	ДанныеБизнесПроцессов.ДатаНачала УБЫВ";
		
		Запрос.УстановитьПараметр("КомплексныйПроцесс", КомплексныйПроцесс);
		Запрос.УстановитьПараметр("БизнесПроцесс", БизнесПроцесс);
		
		Выборка = Запрос.Выполнить().Выбрать();
		Пока Выборка.Следующий() Цикл
			Если ЗначениеЗаполнено(Выборка.БизнесПроцесс) Тогда 				    		
				ИсторияВыполнения = ?(ИсторияВыполнения = "","", ИсторияВыполнения + Символы.ПС + Символы.ПС)
				+ "ПРОЦЕСС " + Строка(Выборка.БизнесПроцесс) + Символы.ПС + Символы.ПС + Доработка_ИсторияПоБизнесПроцессу(Выборка.БизнесПроцесс);
			КонецЕсли;		
		КонецЦикла;
		
		Возврат ИсторияВыполнения;
		
	Иначе
		Возврат Доработка_ИсторияПоБизнесПроцессу(БизнесПроцесс)
	КонецЕсли;
	
	//}

КонецФункции

И добавить функцию:

Функция Доработка_ИсторияПоБизнесПроцессу(БизнесПроцесс) Экспорт
	
	ИсторияВыполнения = "";
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос("ВЫБРАТЬ
		|	ИсторияВыполненияЗадач.Описание
		|ИЗ
		|	РегистрСведений.ИсторияВыполненияЗадач КАК ИсторияВыполненияЗадач
		|ГДЕ
		|	ИсторияВыполненияЗадач.БизнесПроцесс = &БизнесПроцесс");
		
	Запрос.УстановитьПараметр("БизнесПроцесс", БизнесПроцесс);
	Выборка = Запрос.Выполнить().Выбрать();
	
	Если Выборка.Следующий() Тогда
		ИсторияВыполнения = Выборка.Описание;
	КонецЕсли;
	
	Возврат ИсторияВыполнения;

КонецФункции

Надеюсь, кому-то будет полезен данный прием.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Rustig 1419 08.08.18 13:56 Сейчас в теме
(0) история согласования красиво смотрится, думаю полезный функционал

про код:
УстановитьПривилегированныйРежим(Истина);
после этого не надо разве прописывать
УстановитьПривилегированныйРежим(Ложь);
?
2. E_Babaylova 08.08.18 14:43 Сейчас в теме
(1) нет, не нужно. Из синтаксис-помощника: "Для явного выключения привилегированного режима необходимо внутри процедуры или функции, в которой он был включен, вызвать метод с параметром Ложь столько же раз, сколько раз в этой же процедуре или функции был вызван метод с параметром Истина.
Если этого сделано не было, то при возврате из процедуры/функции, в которой был включен привилегированный режим, он будет выключен автоматически (неявно)."
3. vcv 86 09.08.18 14:02 Сейчас в теме
Несколько сложней, но гораздо функциональней изменить общий модуль ОбзорЗадачВызовСервераПереопределяемый.
4. user780057 11.10.19 11:16 Сейчас в теме
Здравствуйте! Мир вашему дому!
История согласования выводится не полностью, проверил по многим документам. На закладке визы в карточке документа, например, пять согласовантов, а с помощью вашего кода выводится два. Я так понимаю, что в комплексном процессе много вложеных процессов согласования с условиями маршрутизации может быть и здесь в коде учитываются не все, а только один.
Хотя при печати карточки документа такой проблемы нет и в согласовании все 5 отображены.
Как можно доработать ваш код?
5. rmIvanT 37 18.11.19 16:47 Сейчас в теме
Мой вариант, чутка сложнее, может кому пригодится ;-)

ОбзорЗадачВызовСервераПереопределяемый
6. rmIvanT 37 19.11.19 11:15 Сейчас в теме
(5) нашлись ошибки в куске копипасты:
//было
//ПредметДокумент = ПолучитьОсновнойПредметДокумент(Задача.Предметы);
//стало
ПредметДокумент = ОбзорЗадачВызовСервера.ПолучитьОсновнойПредметДокумент(Задача.Предметы);
	
Если ЗначениеЗаполнено(ПредметДокумент) Тогда
//было
//	ОбзорПредмета = ПолучитьОбзорПредметаЗадачи(ПредметДокумент);
//стало
	ОбзорПредмета = ОбзорЗадачВызовСервера.ПолучитьОбзорПредметаЗадачи(ПредметДокумент);
	Если Не ПустаяСтрока(ОбзорПредмета) Тогда
		HTMLТекст = HTMLТекст + "<p>" + ОбзорПредмета + "</p>";
	КонецЕсли;	

КонецЕсли;
Показать
7. rmIvanT 37 20.11.19 13:24 Сейчас в теме
Оставьте свое сообщение

См. также

SALE! 30%

Видеокурс-самоучитель "1С:Документооборот - ГУРУ" для самостоятельного внедрения Промо

Пользователю системы Документооборот и делопроизводство v8 ДО Платные (руб)

Самый детальный и самый полный самоучитель по программе 1С:Документооборот, в котором Вы научитесь правильно работать, настраивать, администрировать и внедрять конфигурацию 1С:Документооборот. Все уроки курса построены на последовательном заполнении пустой базы 1С:Документооборот КОРП в клиент-серверном варианте.

89000 руб.

30.10.2018    19186    5    0    

1С: Документооборот. Роли, использующие объекты адресации. Конфигурация остается типовой (используется расширение)

Информационная безопасность v8 ДО Абонемент ($m)

Расширение функционала документооборота. Реализована возможность использования ролей с объектами адресации. Конфигурация остается типовой (используется расширение)

5 стартмани

10.01.2019    6823    15    sulig    21    

Вывод всей истории в задаче комплексного процесса

Практика программирования v8::Бизнес-процессы ДО УУ Бесплатно (free)

В статье описывается, какие изменения нужно сделать, чтобы в задаче комплексного процесса выводилась вся история (по всем процессам), а не только история текущего процесса.

08.08.2018    5995    0    E_Babaylova    7    

Печать pdf документа со штампом ЭЦП

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::УФ ДО Абонемент ($m)

Печать pdf файла, прикрепленного к внутреннему документу, подписанному ЭЦП, с установкой отметки о подписании.

1 стартмани

24.05.2018    13253    88    App0st0l    12    

Перенос документов и процессов между двумя базами 1С:Документооборота Промо

Обработка документов Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО УУ Платные (руб)

Обработка по переносу документов поможет перенести документы и процессы из одной базы 1С:Документооборот в другую. Версии двух баз должны совпадать, а релизы конфигураций 1С:Документооборот могут быть различными. Главное, чтобы была синхронизирована НСИ.

21000 руб.

09.06.2016    19840    8    4    

Эмулятор скриптов в 1С:Документооборот

Документооборот и делопроизводство Инструментарий разработчика Документооборот и делопроизводство v8 ДО Абонемент ($m)

В 1С:Документообороте можно использовать программный код 1С в пользовательском режиме (не в конфигураторе). Однако если в конфигураторе есть отладчик, то в пользовательском режиме протестировать скрипт достаточно сложно. Внешняя обработка Эмулятор скриптов позволяет вывести результаты скрипта и проверить работу алгоритма на разных документах.

2 стартмани

13.12.2017    12604    88    vlush78    0    

Управление договорами в 1С:Документооборот

Управление бизнес-процессами (BPM) Документооборот и делопроизводство Пользователю системы Бухгалтерский учет Документооборот и делопроизводство v8 ДО УУ Бесплатно (free)

В 1С:Документооборот в релизах 2.1.7 и 2.1.8 концепция учета договоров продолжила свое развитие (появились стороны договора). Это повлияло и на бизнес-процессы (теперь вместо процесса Утверждение надо пользоваться процессом Подписание для договоров). Рассмотрим основные моменты, на которые надо обратить внимание при внедрении управления договорами в 1С:Документооборот.

24.01.2017    32961    0    vlush78    0    

Блокировка повторного запуска комплексного процесса в 1С: Документооборот 2

Администрирование данных 1С Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Абонемент ($m)

Острой проблемой при работе документооборота стал повторный запуск комплексного процесса. Пользователи несколько раз  запускали один и тот же комплексный процесс по документу, не убедившись, что этот же процесс уже запущен. В результате наступил хаос, все возмущались и недоумевали, почему один и тот же документ приходил на согласование и исполнение несколько раз. 

2 стартмани

04.10.2016    19331    71    zabaluev    25    

Ограничения запуска процессов в 1С:Документооборот Промо

Обработка документов Обработка справочников v8 ДО Платные (руб)

Расширение "Ограничение запуска процессов" позволяет для разных групп пользователей убрать не нужные типы процессов для запуска для разных видов документов.

21000 руб.

03.04.2017    10579    33    0    

Новое в 1С:Документооборот ред. 2.1

Пользователю системы Управленческий учет (прочее) Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО УУ Бесплатно (free)

Фирма 1С не стоит на месте и продолжает радовать нас своими новыми версиями конфигурации 1С:Документооборот. В конце мая 2016 года вышла новая редакция 2.1, которая содержит как принципиально новые возможности, так и улучшение старых функций. В данной статье будут рассмотрены отличия конфигурации 1С:Документооборот редакции 2.1 по сравнению с редакцией 2.0.

15.06.2016    31312    0    vlush78    7    

Нагрузочное тестирование 1С:Документооборот

Производительность и оптимизация (HighLoad) Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Бесплатно (free)

Перед запуском 1С:Документооборот для средних и крупных внедрений крайне желательно провести нагрузочное тестирование, чтобы проверить корректность и скорость работы системы электронного документооборота в условиях максимальной нагрузки. В данной статье пойдет речь о том, как провести нагрузочное тестирование в 1С:Документооборот без использования 1С:КИП.

28.12.2015    20377    0    vlush78    1    

Права доступа в 1С:Документооборот 2.1 Промо

Информационная безопасность Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Бесплатно (free)

В программе 1С:Документооборот ред 2.1 механизм системы прав доступа сильно изменился. С одной стороны, права доступа в данной версии стали проще и быстрее, с другой стороны - права по рабочим группам объектов теперь могут противоречить политикам доступа. Разберемся в данной статье как работает механизм прав доступа в 1с документообороте 2.1.

16.09.2016    69054    0    vlush78    0